New Account Creation Issue

Incident Report for US Tax Court

Resolved

The root cause has been identified and mitigation has been performed. New accounts can now be created as expected.
Posted Apr 11, 2022 - 10:46 EDT

Investigating

Users creating new DAWSON accounts are experiencing issues logging in. We are actively troubleshooting the issue.
Posted Apr 11, 2022 - 10:15 EDT
This incident affected: DAWSON.