DAWSON Degraded Performance

Incident Report for US Tax Court

Resolved

The service provider has resolved the issue, and we have restored service to DAWSON.

DAWSON is fully operational.
Posted Oct 20, 2025 - 21:34 EDT

Identified

Our service provider is experiencing a degradation in service that impacts DAWSON. Users may experience intermittent errors logging into and using the application.

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:37 EDT
This incident affected: DAWSON.